Nothing happen when press 'New Mesh Asset Instance', and problem when load the scene

0
Thanitsak posted this 07 October 2016

When I pressed New Mesh Asset Instance nothing happen like it used to. There was a box that said saving chunk and nothing happen after this box disappear.


And there is one more thing, when I load my 'home town' scene all of the objects that created from Pica voxel are dark, but when I open 'home town' scene not from other scene that will load to this scene, all of the objects color display normal like it should to be not dark. As you can see from the picture I attached.


Thank you very much and much appreciate!!!

Last edited 07 October 2016

6 Comments
Order By: Standard | Newest | Votes
1
GarethIW posted this 09 October 2016

Hi, sorry I was away for the weekend so didn't have the time to answer.

The New Mesh Asset Instance button doesn't really have a visible effect. All it does is create a new folder in the MeshStore and creates a new copy of the mesh asset files that make up the shape of the volume. I don't know what you mean by "nothing happens like it used to", so if you could give some details into the issues you're having with the meshes I can try to help more.

I can't think of a reason for your PicaVoxel objects to be darker in once scene compared to another, other than regular Unity lighting things. So check the following:

  1. If you have a Directional Light, check that it has the same intensity, color and transform rotation in both scenes.
  2. Compare the lighting settings for both scenes in the Lighting window (menu Window -> Lighting)

If the lighting settings are the same then I will need a copy of your project (or a reproduction in a new project) to help further. You can send that to support@picavoxel.com

0
Thanitsak posted this 10 October 2016

Hi, Thank you very very much, I thought it is going to create like mesh-only copy button. And could you please explain how to use that folder from meshstore or make it same as duplicate it.


I already checked everything that you suggested and the voxel still dark, I just noticed that also the preview of the object in the prefab also dark when open from other scene. I don't quite understand about reproduction in a new project or how to create it ,already search in google but none of them tell me what I need to do.


Much appreciate! :)

1
GarethIW posted this 11 October 2016

If you want to make a copy of a PicaVoxel volume and then make changes to the copy you need to:

  1. Copy the object in Unity normally (with Ctrl+C/Ctrl+V or Duplicate)
  2. Click the "New Mesh Asset Instance" button on the new copy.

The reason for this is explained in this thread.

If you don't want to send me your project to try to find out why the colour changes after scene load, then I will need you to try to make a brand new Unity project that does the same loading between two scenes and see if it has the same problem, and then send me that project, or step-by-step instructions of how to cause the problem. This is known as reproducing the issue.

Last edited 11 October 2016

0
Thanitsak posted this 14 October 2016

Thank you very very much for the answer , I also sent you a email to support@picavoxel.com hope you received it and this nightmare will be gone.

Much appreciate!

1
GarethIW posted this 14 October 2016

This is not a PicaVoxel problem, it is an editor bug: http://answers.unity3d.com/questions/954831/changing-scene-messes-up-lights.html

If you add a normal Unity cube (Create->3D->Cube) to your scene, you will see it has the same colour problems.

I got the lighting to work correctly in your test project by turning off the Auto lightmap bake (bottom of Lighting window), and manually baking both scenes and saving them.

However, you don't even need to do that because if you build the test project you sent me, you don't get the lighting problem in the executable game. It is just a bug in the editor that has gone unfixed since they introduced the new lighting.

0
Thanitsak posted this 16 October 2016

So the conclude is turn off the Auto at the buttom of the lighting window. I think it will dark when I run the game and when change the scene when I turn off the Auto. But when I build the game by build setting it will bright? Thank you very much for your answer!

Much appreciate!


Our 282 members have posted 390 times in 91 discussions